]> patrickod personal git archive - keywing-rs.git/blobdiff - shell.nix
2021 nix flake updates & some minor cleanup
[keywing-rs.git] / shell.nix
index 19b7c155433337b1d8dfda6b9e6407720a39aaa8..1c5dc56149292d4b7c3c158080bf28e8ed4a818d 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,4 @@
 let
-  rust-version = "1.46.0";
-
   nixpkgs = fetchGit {
     url = "https://github.com/patrickod/nixpkgs.git";
     rev = "8bb6ca5f0a93bb0b9264b50a8c56431c7c7cc591";
@@ -21,8 +19,7 @@ let
 
 in
   pkgs.mkShell {
-    name = "rust-dev";
-    nativeBuildInputs = with pkgs; [
+    buildInputs = with pkgs; [
       (rustChannels.stable.rust.override {
         targets = targets;
         extensions = [